Scheduled for July 15, 2024 at 8:30 AM – 9:30 AM
Affects
Third Party Services
Under maintenance from 8:30 AM to 9:30 AM
Digital VAT (UK)
Under maintenance from 8:30 AM to 9:30 AM
Completed
July 15, 2024 at 9:30 AMCompleted
July 15, 2024 at 9:30 AMMaintenance has completed successfully
In progress
July 15, 2024 at 8:30 AMIn progress
July 15, 2024 at 8:30 AMMaintenance is now in progress
Planned
July 15, 2024 at 8:30 AMPlanned
July 15, 2024 at 8:30 AMWe are planning an update to the Making Tax Digital service. During this update, the affected tenants will be unable to log in for approximately 60 minutes. We apologize for any inconvenience this may cause and appreciate your understanding.