All systems operational


For the latest news on whats been released into our Products, please visit the Release Notes.

Next Production Release: evening of 15th June 2021


  • Portal
  • Documentation
  • Planned Release Dates
  • [Resolved] MAN DC connectivity disrupted

    Started on November 23, 2020 at 2:26 PM. Resolved after about 3 hours

    Affected

    Point Of Sale (POS)
    Elastic Search
    Rabbit
    Manchester (MAN)
    • Investigating
      November 23, 2020 at 2:26 PM

      We are currently investigating this incident.

    • Resolved
      November 23, 2020 at 5:27 PM

      Connectivity restored.