All systems operational


For the latest news on whats been released into our Products, please visit the Release Notes.

  • Portal
  • Documentation
  • Clean Cash Unavailable

    Resolved
    Major outage
    Started 9 months ago Lasted about 2 hours

    Affected

    Applications
    Point Of Sale (POS)
    Updates
    • Resolved
      Resolved

      This incident has been resolved.

    • Monitoring
      Monitoring

      We implemented a fix and are currently monitoring the result.

    • Identified
      Identified

      We have identified the cause and are implementing a solution.

    • Investigating
      Investigating

      We have identified that we are unable to reach the CleanCash service which is affecting the use of POS in Sweden. This is under investigation but appears to be on the 3rd party service end. We are in touch with the provider and will update when more information is available.